Variante Bac 2009 informatica neintensiv - PDFCOFFEE.COM (2023)

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 001 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul real memorat în variabila x aparţine intervalului (5,8]? (4p.)

a. (x=5)

b. (x5)

c. (x>8) || (x0 execută a) Scrieţi valoarea care se va afişa dacă se citeşte │ cÅn%10 n=103456. (6p.) │ nÅ[n/10] b) Scrieţi toate numere naturale impare, distincte, fiecare │┌dacă c%3=0 atunci având exact două cifre, care pot fi citite pentru variabila ││ zÅz+p*(9-c) n astfel încât să se afişeze valoarea 3. (4p.) ││ pÅp*10 │└■ c) Scrieţi în pseudocod un algoritm, echivalent cu cel dat, └■ în care să se înlocuiască structura cât timp...execută scrie z cu o structură repetitivă de alt tip. (6p.) d)

Scrieţi programul C/C++ corespunzător algoritmului dat.

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

(10p.)

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 002 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Variabilele x şi y sunt tip int. Care dintre expresiile C/C++ de mai jos are valoarea 1 dacă şi numai dacă valorile întregi nenule memorate în variabilele x şi y sunt egale? (4p.)

a. (x%y==0) && (y%x==0) && (x*y>0)

b. (x=0

d. !(x*(y-5)3) && (a3) || (a3) || (a0 execută │┌dacă n%10 x%y+1 c. !(x/2+2==y) d. x-y+3!=0

1.

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în citeşte n,k (numere naturale) pseudocod. pÅ1 ┌cât timp n>0 şi k>0 execută S-a notat cu x%y restul împărţirii numărului natural x │ cÅn%10 la numărul natural nenul y şi cu [z] partea întreagă a │ ┌dacă c%2=1 atunci numărului real z. │ │ pÅp*c a) Scrieţi valoarea care se va afişa dacă se │ └■ citeşte pentru n valoarea 296385, iar pentru k │ nÅ[n/10] valoarea 3. (6p.) │ kÅk-1 └■ b) Dacă se citeşte pentru k valoarea 4, scrieţi scrie p cea mai mare valoare de 5 cifre care poate fi citită pentru n astfel încât numărul afişat în urma executării algoritmului să fie 1. (4p.) c)

Scrieţi programul C/C++ corespunzător algoritmului dat.

d)

Scrieţi în pseudocod un algoritm echivalent cu algoritmul dat, în care să se înlocuiască cu o structură repetitivă structura repetitivă cât timp...execută, pentru...execută. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

(10p.)

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 012 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă variabilele x şi y memorează două numere naturale pare consecutive? (4p.) (x-y==2) && (y-x==2) (x==2) && (y==4) b. a. x-y==2 d. ((x-y==2) || (y-x==2)) && (x%2==0) c.

1.

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. citeşte x (număr natural) yÅ0 S-a notat cu [c] partea întreagă a numărului real c. ┌cât timp x≠0 execută a) Scrieţi valoarea care va fi afişată dacă se citesc, în │ ┌cât timp x>9 execută │ │ xÅ[x/10] această ordine, numerele 12, 7, 354, 9, 630, 0. │ └■ (6p.) │ yÅy*10+x b) Scrieţi un şir de numere ce pot fi citite astfel încât │ citeşte x valoarea afişată să fie 321. (4p.) └■ scrie y 2. Se consideră pseudocod.

algoritmul

alăturat,

descris

în

c)

Scrieţi programul C/C++ corespunzător algoritmului dat.

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare dintre cele două structuri cât timp...execută, cu câte o structură repetitivă cu test final. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

(10p.)

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 013 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. Care dintre expresiile C/C++ de mai jos este echivalentă cu !((a7)) expresia alăturată? (4p.) b. !(a7) a. (a>=5)&&(b=5) && !(b0 execută │ │ ┌dacă n%2=1 atunci │ │ │ cÅc+1 │ │ └■ │ │ nÅ[n/10] │ └■ │ ┌dacă c>0 atunci │ │ kÅk+1 │ └■ └■ scrie k

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 014 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Pentru care dintre perechile de valori (a%100==b%100) && (a>99) || (b>99) de mai jos expresia C/C++ alăturată are valoarea 1? (4p.)

a. a=1003 şi b=3 c. a=1100 şi b=10

b. a=35 şi b=35 d. a=1234 şi b=12

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră pseudocod.

algoritmul

alăturat,

descris

în

S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z. a)

Scrieţi valoarea ce se va afişa dacă se citesc, în această ordine, numerele 12, 7, 354, 9, 1630, 0. (6p.)

b)

Scrieţi un set de date de intrare format din numere pare, care să determine, în urma executării algoritmului, afişarea valorii 751. (4p.)

c)

Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare structură cât timp...execută, cu câte o structură repetitivă cu test final. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

citeşte x (număr natural) nÅ0 ┌cât timp x≠0 execută │ yÅx; cÅ0 │ ┌cât timp y>0 execută │ │ ┌dacă y%10>c atunci │ │ │ cÅy%10 │ │ └■ │ │ yÅ[y/10] │ └■ │ nÅn*10+c │ citeşte x └■ scrie n

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 015 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Variabilele x şi y sunt de tip întreg, x memorând valoarea 4, iar y valoarea 2. Care dintre expresiile C/C++ de mai jos are valoarea 0? (4p.)

a. x-y!=0

b. x+y>x%y+1

c. x-2*y==0

d. !(x==2*y)

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu x%y restul împărţirii numărului natural x la numărul natural nenul y.

citeşte a,n (numere naturale) ┌pentru iÅ1,n execută │ ┌dacă i%2=0 atunci │ │ aÅa-i*i │ │altfel │ │ aÅa+i*i │ └■ └■ scrie a

a)

Scrieţi valoarea care se afişează dacă pentru a se citeşte valoarea 25, iar pentru n se citeşte valoarea 6. (6p.)

b)

Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

c)

Dacă pentru variabila a se citeşte valoarea 18, scrieţi valoarea care trebuie citită pentru variabila n, astfel încât să se afişeze numărul 8. (6p.)

d)

Dacă se citeşte pentru a valoarea 0, cu ce instrucţiune de atribuire trebuie înlocuită atribuirea aÅa-i*i în algoritmul dat, astfel încât algoritmul obţinut să afişeze valoarea expresiei n2 dacă numărul citit pentru n este impar şi respectiv 0 dacă numărul citit pentru n este par. (4p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 016 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Care dintre următoarele instrucţiuni C/C++ determină inserarea cifrei 7 în faţa ultimei cifre a unui număr natural, cu mai mult de 2 cifre, memorat în variabila x? (4p.)

a. x=(x/10*10+7)*10+x%10;

b. x=x/10+7+x%10;

c. x=(x%10*10+7)*10+x/10;

d. x=(x/10+7)*10+x%10;

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu cu x%y restul împărţirii numărului natural x la numărul natural, nenul, y. a)

b)

citeşte n (număr natural nenul) ┌pentru iÅ1,n-1 execută │┌dacă i%2=0 atunci ││ scrie ’#’ │└■ Scrieţi caracterele care se vor afişa în urma │┌pentru jÅi+1,n execută executării algoritmului dacă se citeşte valoarea 4. ││ scrie ’*’ │└■ (6p.) └■ Scrieţi o valoare care poate fi citită pentru variabila n, astfel încât caracterul * să fie afişat de exact 66 de ori. (4p.)

c)

Scrieţi programul algoritmului dat.

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască fiecare structură repetitivă pentru...execută cu câte o structură repetitivă cât timp...execută. (6p.)

C/C++

corespunzător (10p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 017 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Care este valoarea pe care poate să o aibă y=0; iniţial variabila întreagă x dacă, la sfârşitul do { x=x/10; executării secvenţei alăturate, variabila y=y+1; întreagă y are valoarea 2? (4p.) } while(x%100==0);

a. 300

b. 5000

c. 120

d. 0

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră algoritmul alăturat, descris în pseudocod. a)

Scrieţi succesiunea de caractere pe care le va afişa algoritmul dacă se citesc, în aceasta ordine, valorile 2, respectiv 9. (6p.)

b)

Scrieţi numărul de perechi de valori aparţinând intervalului [1,20], care pot fi citite pentru variabilele x şi y, astfel încât rezultatul afişat să fie format din exact 12 caractere ? (4p.)

c)

Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura repetitivă cât timp...execută cu o structură repetitivă de alt tip. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

citeşte x,y (numere naturale) ┌dacă xy atunci numărul natural, nenul, b şi cu aÅÆb interschimbarea │ yÅÆx valorilor reţinute de variabilele a şi b. └■ Scrieţi succesiunea de caractere care se vor afişa în ┌dacă x%2=0 atunci a) urma executării algoritmului dacă se citesc, în acestă │ xÅx+1 ordine, valorile 2 şi 9. (6p.) └■ Ştiind că pentru variabila y se citeşte valoarea 79, ┌cât timp x≤y execută b) │ xÅx+2 scrieţi două valori distincte care pot fi citite pentru │ scrie ‘*’ variabila x, astfel încât să fie afişat de exact 40 de ori └■ caracterul *. (4p.) c)

Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura repetitivă cât timp...execută cu o structură repetitivă de alt tip. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 019 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Câte atribuiri se execută, în total, în p=1; n=279; secvenţa alăturată, dacă n şi p sunt while (n>=100) variabile de tip întreg? (4p.) { p=p*10; n=n-100; }

a. 4

b. 6

c. 2

d. 8

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. citeşte a,b (numere naturale) aÅ[a/10]%10*10+a%10 bÅ[b/10]%10*10+b%10 ┌pentru iÅa,b execută │┌dacă[i/10]=i%10 atunci Scrieţi numerele care se vor afişa în urma ││ scrie i%10 executării algoritmului dacă se citesc valorile │└■ a=312 şi b=1354. (6p.) └■

2. Se consideră algoritmul alăturat, descris în pseudocod. S-a notat cu cu x%y restul împărţirii numărului natural x la numărul natural nenul y şi cu [z] partea întreagă a numărului real z. a)

b)

Scrieţi câte o valoare care poate fi citită pentru variabila a, respectiv b, astfel încât algoritmul să afişeze exact 2 valori. (4p.)

c)

Scrieţi programul algoritmului dat.

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura pentru...execută cu o structură repetitivă de alt tip. (6p.)

C/C++

corespunzător (10p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 020 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Care este valoarea tipărită de secvenţa de program C/C++ alăturată, ştiind că x şi y sunt variabile întregi, iar z este o variabilă reală? (4p.)

a. 5

b. 5.833333

x=30; y=5; z=(x+y)/6.0; z=floor(z*100); z=z/100; coutb atunci Scrieţi cea mai mică valoare de patru cifre distincte ││ mÅm*10+b b) care poate fi citită pentru variabila n, astfel încât să se ││ aÅb afişeze valoarea 0. (4p.) │└■ └■ Scrieţi programul C/C++ corespunzător algoritmului scrie m c) dat. (10p.) d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât timp...execută cu o structură repetitivă de alt tip. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 021 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. v1=0; v2=0; 1. Care dintre expresiile C/C++ de mai jos are for(i=1;i0 atunci numărul n=5172. (6p.) │ │cÅc-1 b) Scrieţi programul C/C++ corespunzător algoritmului dat. │ └■ (10p.) │ mÅm+c*p │ pÅp*10 c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, │ nÅ[n/10] în care să se înlocuiască structura └■ cât timp...execută cu o structură repetitivă de un scrie m alt tip. (6p.) d)

Scrieţi toate valorile distincte, fiecare având exact patru cifre, care pot fi citite pentru variabila n astfel încât să se afişeze valoarea 2008, pentru fiecare dintre acestea. (4p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 031 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Se consideră variabila a care memorează un număr cu exact 6 cifre. Care dintre expresiile C/C++ de mai jos are ca valoare numărul format din cele două cifre din mijloc ale valorii memorate în a? (4p.)

a. (a%100)/100

b. a/100%100

c. a/1000+a%1000

d. a/100%10+a/1000%10

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. citeşte a 2. Se consideră algoritmul alăturat, descris în pseudocod: (număr natural, a>0) S-a notat cu [x], partea întreagă a numărului real x. kÅ0 bÅ[(a+1)*(a+2)/2] a) Scrieţi valorile care se vor afişa pentru a=9. ┌cât timp b≥a execută (4p.) │ bÅb-a b) Scrieţi numărul valorilor din intervalul [1,5] care, citite │ kÅk+1 pentru variabila a, determină, după executarea └■ algoritmului alăturat, memorarea valorii 1 în variabila b. scrie b,k (6p.) c)

Scrieţi programul C/C++ corespunzător algoritmului dat. (10p.)

d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să nu se utilizeze structuri repetitive sau subprograme recursive. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 032 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect 1.

Stabiliţi care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul întreg memorat în variabila x nu aparţine intervalului (-35,-20)∪[17,100]. (4p.)

a. (x100) b. (x=100) c. (x100) d. (x100) Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. citeşte a,b 2. Se consideră algoritmul alăturat, descris în pseudocod. (numere naturale) ┌dacă a>b atunci a) Scrieţi numerele care sunt afişate dacă pentru a şi b │ cÅb se citesc valorile a=150 şi b=9. (4p.) │ bÅa b) Dacă pentru b se citeşte valoarea 150, scrieţi cea mai │ aÅc mare valoare care se poate citi pentru a, astfel încât └■ algoritmul să afişeze exact 4 valori. (6p.) ┌cât timp ac atunci executării algoritmului. (4p.) │ │ xÅc │ └■ Scrieţi programul C/C++ corespunzător │ ┌dacă x≠a atunci algoritmului dat. (10p.) │ │ aÅa-x Scrieţi în pseudocod un algoritm echivalent cu │ └■ cel dat în care să se înlocuiască structura │ ┌dacă x≠b atunci bÅb-x repetitivă cât timp...execută cu o │ │ structură repetitivă cu test final. (6p.) │ └■ │ ┌dacă x≠c atunci │ │ cÅc-x │ └■ └■ scrie a

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 088 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

a. c.

In secvenţele C/C++ următoare toate variabilele sunt de tip întreg şi memorează numere cu cel mult 3 cifre. Care dintre variantele de mai jos determină interschimbarea valorilor memorate de variabilele a şi b? (4p.) aux=b; a=b; b=aux; a=a+b; b=a-b; a=a-b; b. a=b; b=a; a=a+b; b=a-b; a=b-a; d.

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră pseudocod.

algoritmul

alăturat,

descris

în

citeşte a (număr natural)

S-a notat cu x%y restul împărţirii numărului natural x la pÅ1 numărul natural nenul y, iar cu [z] partea întreagă a bÅ0 numărului real z. ┌cât timp a≠0 execută Scrieţi numărul care se va afişa dacă se citeşte │ cÅa%10 a) valoarea 123456. (6p.) │ ┌dacă a%2=0 atunci │ │ bÅb+c*p b) Scrieţi o valoare cu exact 5 cifre care poate fi citită │ │altfel pentru variabila a astfel încât numărul afişat să fie │ │ bÅb*10+c format din toate cifrele lui a, scrise în ordine inversă. │ └■ (4p.) │ aÅ[a/10] │ pÅp*10 c) Scrieţi programul C/C++ corespunzător algoritmului └■ dat. (10p.) d)

Scrieţi în pseudocod un algoritm echivalent cu cel dat în care să se înlocuiască structura cât timp ... execută cu o structură repetitivă cu test final. (6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

scrie b

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 089 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. 1.

Variabila întregă n memorează un număr natural format din exact două cifre nenule. Care dintre următoarele instrucţiuni C/C++ determină memorarea în variabila întreagă t a numărului care are aceleaşi cifre ca şi n, dar în ordine inversă? (4p.) b. t=n/10*10+n%10; a. t=n%10*10+n/10; d. t=n%10*10+t/10; c. t=n%10+n/10;

Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare. 2. Se consideră pseudocod.

algoritmul

alăturat,

descris

în

citeşte n (număr natural)

S-a notat cu x%y restul împărţirii numărului natural x la tÅn; rÅ0 numărul natural nenul y, iar cu [z] partea întreagă a ┌cât timp t>0 execută numărului real z. │┌dacă (t%10)%2=1 atunci a) Scrieţi numărul care se va afişa dacă se citeşte numărul ││ rÅr*10+1 ││altfel n=3072941. (6p.) ││ rÅr*10+t%10 b) Scrieţi un număr format din exact 5 cifre, ele fiind în │└■ ordine strict crescătoare, care poate fi citit astfel încât │ tÅ[t/10] executarea algoritmului să determine afişarea unui └■ număr egal cu cel citit. (4p.) nÅ0 ┌cât timp r>0 execută c) Scrieţi programul C/C++ corespunzător algoritmului dat. │ nÅn*10+r%10 (10p.) │ rÅ[r/10] d) Scrieţi în pseudocod un algoritm echivalent cu cel dat în └■ care să se înlocuiască fiecare structură cât timp… scrie n execută cu câte o structură repetitivă cu test final.(6p.)

BACALAUREAT 2009 - INFORMATICĂ, limbajul C/C++ Specializarea Matematică-informatică

Subiectul I

Ministerul Educaţiei, Cercetării şi Inovării Centrul Naţional pentru Curriculum şi Evaluare în Învăţământul Preuniversitar

EXAMENUL DE BACALAUREAT – 2009 Proba scrisă la INFORMATICĂ PROBA E, limbajul C/C++ Specializarea Matematică-informatică ♦ Toate subiectele sunt obligatorii. Se acordă 10 puncte din oficiu. ♦ Timpul efectiv de lucru este de 3 ore. ♦ În rezolvările cerute, identificatorii utilizaţi trebuie să respecte precizările din enunţ (bold), iar în lipsa unor precizări explicite, notaţiile trebuie să corespundă cu semnificaţiile asociate acestora (eventual în formă prescurtată). Subiectul I (30 de puncte) - Varianta 090 Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect. Care dintre următoarele instrucţiuni C/C++ atribuie variabilei întregi t valoarea -1 dacă şi numai dacă variabilele întregi a şi b sunt nenule şi au semne diferite? (4p.) b. if ((a>0)&&(b0)||(b

Top Articles
Latest Posts
Article information

Author: Nathanial Hackett

Last Updated: 03/25/2023

Views: 5900

Rating: 4.1 / 5 (72 voted)

Reviews: 87% of readers found this page helpful

Author information

Name: Nathanial Hackett

Birthday: 1997-10-09

Address: Apt. 935 264 Abshire Canyon, South Nerissachester, NM 01800

Phone: +9752624861224

Job: Forward Technology Assistant

Hobby: Listening to music, Shopping, Vacation, Baton twirling, Flower arranging, Blacksmithing, Do it yourself

Introduction: My name is Nathanial Hackett, I am a lovely, curious, smiling, lively, thoughtful, courageous, lively person who loves writing and wants to share my knowledge and understanding with you.